CVE-2016-9587
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed
02 Description
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 17.14% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 97.0% of scored records. A rank, not a probability.
- NVD base score
- 8.1 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Important. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-04-24 16:00Z8 YR AGO
- Last updated
- 2024-08-06 02:59Z2 YR AGO
- Reserved
- 2016-11-23
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Medium (CVSS 6.6)
- CNA CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20Improper Input ValidationClass
- Data version
- 5.1
- Document digest
- 3b4dff51c6c27d7535d1209f878ba9f4bd1984a74e825a50d524ac2fb82af77b
05 Affected products
06 References
- access.redhat.comRHSA-2017:0515https://access.redhat.com/errata/RHSA-2017:0515
- www.exploit-db.com41013https://www.exploit-db.com/exploits/41013/
- security.gentoo.orgGLSA-201701-77https://security.gentoo.org/glsa/201701-77
- access.redhat.comRHSA-2017:1685https://access.redhat.com/errata/RHSA-2017:1685
- www.securityfocus.com95352http://www.securityfocus.com/bid/95352
- access.redhat.comRHSA-2017:0448https://access.redhat.com/errata/RHSA-2017:0448
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9587
- rhn.redhat.comRHSA-2017:0195http://rhn.redhat.com/errata/RHSA-2017-0195.html
- rhn.redhat.comRHSA-2017:0260http://rhn.redhat.com/errata/RHSA-2017-0260.html
07 Fixed in
Arch Linux
- ansible Fixed in 2.2.1.0rc5-3
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Debian 12
- ansible Fixed in 2.2.0.0-3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- ansible Fixed in 2.2.0.0-3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- ansible Fixed in 2.2.0.0-3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- ansible Fixed in 2.0.0.2-2ubuntu1.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.