CVE-2016-7398
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers
02 Description
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 6.79% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 93.9% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-09-06 18:46Z7 YR AGO
- Last updated
- 2024-08-06 01:57Z2 YR AGO
- Reserved
- 2016-09-09
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-704Incorrect Type Conversion or CastClass
- Data version
- 5.1
- Document digest
- e30d01cf54879b3967ce7713d4b4f6d52bb20848a18d4865ce8a09a1a5d1c054
05 Affected products
06 References
- bugs.php.nethttps://bugs.php.net/bug.php?id=73055
- github.comhttps://github.com/m6w6/ext-http/commit/17137d4ab1ce81a2cee0fae842340a344ef3da83
- bugs.php.nethttps://bugs.php.net/bug.php?id=73055&edit=1
- lists.debian.org[debian-lts-announce] 20190920 [SECURITY] [DLA 1929-1] php-pecl-http security updatehttps://lists.debian.org/debian-lts-announce/2019/09/msg00022.html
07 Fixed in
Debian 12
- php-pecl-http Fixed in 3.1.0+2.6.0-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- php-pecl-http Fixed in 3.1.0+2.6.0-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- php-pecl-http Fixed in 3.1.0+2.6.0-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- php-pecl-http No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.