CVE-2016-6128
The gdImageCropThreshold function in gd_crop.c in the GD Graphics Library (aka libgd) before 2.2.3, as used in PHP before 7.0.9, allows remote attackers to cause a denial of service (application
02 Description
The gdImageCropThreshold function in gd_crop.c in the GD Graphics Library (aka libgd) before 2.2.3, as used in PHP before 7.0.9, allows remote attackers to cause a denial of service (application
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 6.80% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 93.9% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Low. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2016-08-07 10:00Z10 YR AGO
- Last updated
- 2024-08-06 01:22Z2 YR AGO
- Reserved
- 2016-06-29
- Assigning CNA
- debian
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-20Improper Input ValidationClass
- Data version
- 5.1
- Document digest
- 9272cddd9cf37e7a123e0effcc566e721081938772bbcbf44abfd23724c02c01
05 Affected products
06 References
- lists.opensuse.orgopenSUSE-SU-2016:2117http://lists.opensuse.org/opensuse-updates/2016-08/msg00086.html
- www.openwall.com[oss-security] 20160629 Re: CVE Request: libgd: Invalid color index is not properly handled leading to denial of service (crash)http://www.openwall.com/lists/oss-security/2016/06/30/1
- www.securityfocus.com91509http://www.securityfocus.com/bid/91509
- libgd.github.iohttps://libgd.github.io/release-2.2.3.html
- bugs.php.nethttps://bugs.php.net/72494
- lists.opensuse.orgopenSUSE-SU-2016:2363http://lists.opensuse.org/opensuse-updates/2016-09/msg00078.html
- rhn.redhat.comRHSA-2016:2750http://rhn.redhat.com/errata/RHSA-2016-2750.html
- www.securitytracker.com1036276http://www.securitytracker.com/id/1036276
- github.comhttps://github.com/libgd/libgd/commit/6ff72ae40c7c20ece939afb362d98cc37f4a1c96
- security.gentoo.orgGLSA-201612-09https://security.gentoo.org/glsa/201612-09
- www.debian.orgDSA-3619http://www.debian.org/security/2016/dsa-3619
- www.ubuntu.comUSN-3030-1http://www.ubuntu.com/usn/USN-3030-1
- github.comhttps://github.com/libgd/libgd/commit/1ccfe21e14c4d18336f9da8515cd17db88c3de61
07 Fixed in
Debian 12
- libgd2 Fixed in 2.2.2-29-g3c2b605-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- libgd2 Fixed in 2.2.2-29-g3c2b605-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- libgd2 Fixed in 2.2.2-29-g3c2b605-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- libgd2 Fixed in 2.1.0-3ubuntu0.2
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- libgd2 Fixed in 2.1.1-4ubuntu0.16.04.2
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.