CVE-2016-5096
Integer overflow in the fread function in ext/standard/file.c in PHP before 5.5.36 and 5.6.x before 5.6.22 allows remote attackers to cause a denial of service or possibly have unspecified other
02 Description
Integer overflow in the fread function in ext/standard/file.c in PHP before 5.5.36 and 5.6.x before 5.6.22 allows remote attackers to cause a denial of service or possibly have unspecified other
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 4.27% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 90.7% of scored records. A rank, not a probability.
- NVD base score
- 8.6 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Low. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2016-08-07 10:00Z10 YR AGO
- Last updated
- 2024-08-06 00:53Z2 YR AGO
- Reserved
- 2016-05-26
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-190Integer Overflow or WraparoundBase
- Data version
- 5.1
- Document digest
- 6cc4cea42b3e73464db539d670c868877b9c57cc311fc585406fa6e41a3cea45
05 Affected products
06 References
- www.openwall.com[oss-security] 20160526 Re: Fwd: CVE for PHP 5.5.36 issueshttp://www.openwall.com/lists/oss-security/2016/05/26/3
- rhn.redhat.comRHSA-2016:2750http://rhn.redhat.com/errata/RHSA-2016-2750.html
- www.debian.orgDSA-3602http://www.debian.org/security/2016/dsa-3602
- php.nethttp://php.net/ChangeLog-5.php
- h20566.www2.hpe.comhttps://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731
- www.securityfocus.com90861http://www.securityfocus.com/bid/90861
- bugs.php.nethttps://bugs.php.net/bug.php?id=72114
- github.comhttps://github.com/php/php-src/commit/abd159cce48f3e34f08e4751c568e09677d5ec9c?w=1
07 Fixed in
Ubuntu 14.04 LTS
- php5 Fixed in 5.5.9+dfsg-1ubuntu4.19
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.