CVE-2016-2563
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute
02 Description
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 32.80% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 98.3% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2016-04-07 23:00Z10 YR AGO
- Last updated
- 2024-08-05 23:32Z2 YR AGO
- Reserved
- 2016-02-25
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-119Improper Restriction of Operations within the Bounds of a Memory BufferClass
- Data version
- 5.1
- Document digest
- a823230f8ad80977e04aed1e0bd08bf2cc625058c9d6e8f13aca876933c12110
05 Affected products
06 References
- lists.opensuse.orgopenSUSE-SU-2016:1453http://lists.opensuse.org/opensuse-updates/2016-05/msg00131.html
- www.securitytracker.com1035257http://www.securitytracker.com/id/1035257
- security.gentoo.orgGLSA-201606-01https://security.gentoo.org/glsa/201606-01
- www.securityfocus.com84296http://www.securityfocus.com/bid/84296
- www.chiark.greenend.org.ukhttp://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-pscp-sink-sscanf.html
- github.comhttps://github.com/tintinweb/pub/tree/master/pocs/cve-2016-2563
- seclists.org20160309 CVE-2016-2563 - PuTTY/PSCP <=0.66 buffer overflow - vuln-pscp-sink-sscanfhttp://seclists.org/fulldisclosure/2016/Mar/22
07 Fixed in
Debian 12
- putty Fixed in 0.67-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- putty Fixed in 0.67-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- putty Fixed in 0.67-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.