CVE-2016-10148
The wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPress before 4.6 makes a get_plugin_data call before checking the update_plugins capability, which allows remote
02 Description
The wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPress before 4.6 makes a get_plugin_data call before checking the update_plugins capability, which allows remote
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.64% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 75.9% of scored records. A rank, not a probability.
- NVD base score
- 4.3 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-01-18 21:00Z9 YR AGO
- Last updated
- 2024-08-06 03:14Z2 YR AGO
- Reserved
- 2017-01-18
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- f8bbad30fb162434168363483f414f43dcef72a2912d1e82771dc4c9f88880ee
05 Affected products
06 References
- www.securityfocus.com96847http://www.securityfocus.com/bid/96847
- www.openwall.com[oss-security] 20160820 Path traversal vulnerability in WordPress Core Ajax handlershttp://www.openwall.com/lists/oss-security/2016/08/20/1
- core.trac.wordpress.orghttps://core.trac.wordpress.org/changeset/38168
- sumofpwn.nlhttps://sumofpwn.nl/advisory/2016/path_traversal_vulnerability_in_wordpress_core_ajax_handlers.html
- core.trac.wordpress.orghttps://core.trac.wordpress.org/ticket/37490
07 Fixed in
Debian 12
- wordpress Fixed in 4.6.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.6.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.6.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.