CVE-2015-8852
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated
02 Description
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 3.52% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 88.7% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Important. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2016-04-25 14:00Z10 YR AGO
- Last updated
- 2024-08-06 08:29Z2 YR AGO
- Reserved
- 2016-04-18
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-113Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting')Variant
- Data version
- 5.1
- Document digest
- 1e98d365babc8158b632d3cfad37a81ace667af3930f45fb229efbd96b36090a
05 Affected products
06 References
- www.debian.orgDSA-3553http://www.debian.org/security/2016/dsa-3553
- www.varnish-cache.org[varnish-announce] 20150323 Varnish 3.0.7 released.https://www.varnish-cache.org/lists/pipermail/varnish-announce/2015-March/000701.html
- www.openwall.com[oss-security] 20160418 Re: CVE request: Varnish 3 before 3.0.7 was vulnerable to HTTP Smuggling issues: Double Content Length and bad EOLhttp://www.openwall.com/lists/oss-security/2016/04/18/7
- security.gentoo.orgGLSA-201607-10https://security.gentoo.org/glsa/201607-10
- github.comhttps://github.com/varnish/Varnish-Cache/commit/29870c8fe95e4e8a672f6f28c5fbe692bea09e9c
- github.comhttps://github.com/varnish/Varnish-Cache/commit/85e8468bec9416bd7e16b0d80cb820ecd2b330c3
- www.openwall.com[oss-security] 20160416 CVE request: Varnish 3 before 3.0.7 was vulnerable to HTTP Smuggling issues: Double Content Length and bad EOLhttp://www.openwall.com/lists/oss-security/2016/04/16/1
- lists.opensuse.orgopenSUSE-SU-2016:1316http://lists.opensuse.org/opensuse-updates/2016-05/msg00064.html
07 Fixed in
Debian 12
- varnish Fixed in 4.0.0-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- varnish Fixed in 4.0.0-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- varnish Fixed in 3.0.5-2ubuntu0.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.