CVE-2015-6831
Multiple use-after-free vulnerabilities in SPL in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 allow remote attackers to execute arbitrary code via vectors involving (1)
02 Description
Multiple use-after-free vulnerabilities in SPL in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 allow remote attackers to execute arbitrary code via vectors involving (1)
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 7.05% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 94.1% of scored records. A rank, not a probability.
- NVD base score
- 7.3 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2016-01-19 02:00Z10 YR AGO
- Last updated
- 2024-08-06 07:36Z2 YR AGO
- Reserved
- 2015-09-08
- Assigning CNA
- microfocus
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-416Use After FreeVariant
- Data version
- 5.1
- Document digest
- b28b660115cccc90767445f6699923516191829a0441d1163b21fa5a188824fc
05 Affected products
06 References
- www.debian.orgDSA-3344http://www.debian.org/security/2015/dsa-3344
- www.securityfocus.com76737http://www.securityfocus.com/bid/76737
- bugs.php.nethttps://bugs.php.net/bug.php?id=70169
- bugs.php.nethttps://bugs.php.net/bug.php?id=70168
- www.openwall.com[oss-security] 20150819 CVE Request: more php unserializing issueshttp://www.openwall.com/lists/oss-security/2015/08/19/3
- www.php.nethttp://www.php.net/ChangeLog-5.php
- bugs.php.nethttps://bugs.php.net/bug.php?id=70166
- bugs.php.nethttps://bugs.php.net/bug.php?id=70155
- security.gentoo.orgGLSA-201606-10https://security.gentoo.org/glsa/201606-10
07 Fixed in
Ubuntu 14.04 LTS
- php5 Fixed in 5.5.9+dfsg-1ubuntu4.13
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.