CVE-2015-5730
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to
02 Description
The sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 7.34% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 93.9% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2015-11-09 11:00Z10 YR AGO
- Last updated
- 2024-08-06 06:59Z2 YR AGO
- Reserved
- 2015-08-04
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-200Exposure of Sensitive Information to an Unauthorized ActorClass
- Data version
- 5.1
- Document digest
- 11eb38ac751414686596c4ae412703d4c01d1164e66d01fde36d8e9cb33084b4
05 Affected products
06 References
- wordpress.orghttps://wordpress.org/news/2015/08/wordpress-4-2-4-security-and-maintenance-release/
- core.trac.wordpress.orghttps://core.trac.wordpress.org/changeset/33535
- www.securityfocus.com76160http://www.securityfocus.com/bid/76160
- openwall.com[oss-security] 20150804 Re: CVE request: WordPress 4.2.3 and earlier multiple vulnerabilitieshttp://openwall.com/lists/oss-security/2015/08/04/7
- www.securitytracker.com1033178http://www.securitytracker.com/id/1033178
- www.debian.orgDSA-3332http://www.debian.org/security/2015/dsa-3332
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/8130
- core.trac.wordpress.orghttps://core.trac.wordpress.org/changeset/33536
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.2.4
07 Fixed in
Debian 12
- wordpress Fixed in 4.2.4+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.2.4+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.2.4+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.