CVE-2015-5315
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a
02 Description
The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.52% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 84.7% of scored records. A rank, not a probability.
- NVD base score
- 5.9 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Low. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-02-21 16:00Z8 YR AGO
- Last updated
- 2024-08-06 06:41Z2 YR AGO
- Reserved
- 2015-07-01
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- 406377da903693420d2a9bfa7d7aa810fa403227ce3d83b9b8502c7b597157f4
05 Affected products
06 References
- www.ubuntu.comUSN-2808-1http://www.ubuntu.com/usn/USN-2808-1
- www.debian.orgDSA-3397https://www.debian.org/security/2015/dsa-3397
- w1.fihttp://w1.fi/security/2015-7/eap-pwd-missing-last-fragment-length-validation.txt
- www.openwall.com[oss-security] 20151110 hostapd/wpa_supplicant: EAP-pwd missing last fragment length validationhttp://www.openwall.com/lists/oss-security/2015/11/10/10
07 Fixed in
Debian 12
- wpa Fixed in 2.3-2.3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wpa Fixed in 2.3-2.3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wpa Fixed in 2.3-2.3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- wpa Fixed in 2.1-0ubuntu1.4
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.