CVE-2015-5314
The eap_pwd_process function in eap_server/eap_server_pwd.c in hostapd 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when used with (1) an internal
02 Description
The eap_pwd_process function in eap_server/eap_server_pwd.c in hostapd 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when used with (1) an internal
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.27% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 82.9% of scored records. A rank, not a probability.
- NVD base score
- 5.9 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-02-21 16:00Z8 YR AGO
- Last updated
- 2024-08-06 06:41Z2 YR AGO
- Reserved
- 2015-07-01
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-119Improper Restriction of Operations within the Bounds of a Memory BufferClass
- Data version
- 5.1
- Document digest
- 88d0c9aecc7b9ec5a5c9f4b9e985e0b55fc6e2f6cf1114bf0a9b7ec8ff6b4799
05 Affected products
06 References
- www.ubuntu.comUSN-2808-1http://www.ubuntu.com/usn/USN-2808-1
- www.debian.orgDSA-3397https://www.debian.org/security/2015/dsa-3397
- w1.fihttp://w1.fi/security/2015-7/eap-pwd-missing-last-fragment-length-validation.txt
- www.openwall.com[oss-security] 20151110 hostapd/wpa_supplicant: EAP-pwd missing last fragment length validationhttp://www.openwall.com/lists/oss-security/2015/11/10/10
07 Fixed in
Debian 12
- wpa Fixed in 2.3-2.3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wpa Fixed in 2.3-2.3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wpa Fixed in 2.3-2.3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- wpa Fixed in 2.1-0ubuntu1.4
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.