CVE-2015-3429
Cross-site scripting (XSS) vulnerability in example.html in Genericons before 3.3.1, as used in WordPress before 4.2.2, allows remote attackers to inject arbitrary web script or HTML via a fragment
02 Description
Cross-site scripting (XSS) vulnerability in example.html in Genericons before 3.3.1, as used in WordPress before 4.2.2, allows remote attackers to inject arbitrary web script or HTML via a fragment
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 3.91% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 89.9% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2015-06-17 18:00Z11 YR AGO
- Last updated
- 2024-08-06 05:47Z2 YR AGO
- Reserved
- 2015-04-27
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.1
- Document digest
- 4c92b96379aac85da4880c24b82383f7b4491c744ecb639f959e7d849f28fc7b
05 Affected products
06 References
- www.digitalocean.comhttps://www.digitalocean.com/community/tutorials/how-to-protect-your-wordpress-site-from-the-genericons-example-html-xss-vulnerability
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/7965
- www.securityfocus.com20150507 Wordpress Twenty Fifteen Theme - DOM XSS Vulnerability - CVE-2015-3429http://www.securityfocus.com/archive/1/535486/100/1000/threaded
- www.debian.orgDSA-3328http://www.debian.org/security/2015/dsa-3328
- lists.fedoraproject.orgFEDORA-2015-6790http://lists.fedoraproject.org/pipermail/package-announce/2015-May/158278.html
- github.comhttps://github.com/Automattic/Genericons/commit/798ac98579dd72dfdb11bdee3e7bebf01cffb1f7
- wordpress.orghttps://wordpress.org/news/2015/05/wordpress-4-2-2/
- www.netsparker.comhttps://www.netsparker.com/cve-2015-3429-dom-xss-vulnerability-in-twenty-fifteen-wordpress-theme/
- seclists.org20150509 Wordpress Twenty Fifteen Theme - DOM XSS Vulnerability - CVE-2015-3429http://seclists.org/fulldisclosure/2015/May/41
- www.securityfocus.com74534http://www.securityfocus.com/bid/74534
- lists.fedoraproject.orgFEDORA-2015-6808http://lists.fedoraproject.org/pipermail/package-announce/2015-May/158271.html
- packetstormsecurity.comhttp://packetstormsecurity.com/files/131802/WordPress-Twenty-Fifteen-4.2.1-Cross-Site-Scripting.html
07 Fixed in
Debian 12
- wordpress Fixed in 4.2.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.2.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.2.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.