synced 10 MIN AGO
01 Record

CVE-2015-3167

contrib/pgcrypto in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 uses different error responses when an incorrect key is used, which

UnratedPUBLISHEDCNA: redhat
CNA base scoreUnratedNo CNA CVSS vector

02 Description

contrib/pgcrypto in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 uses different error responses when an incorrect key is used, which

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
4.12% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 90.4% of scored records. A rank, not a probability.
NVD base score
7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
Low. Red Hat's rating for its own products, not a CVSS rating.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2019-11-20 20:50Z6 YR AGO
Last updated
2024-08-06 05:39Z2 YR AGO
Reserved
2015-04-10
Assigning CNA
redhat
Record state
PUBLISHED
Severity
Not rated by the issuing CNA
CNA CVSS vector
Not published by the issuing CNA
Weaknesses
  • CWE-200Exposure of Sensitive Information to an Unauthorized ActorClass
  • CWE-209Generation of Error Message Containing Sensitive InformationBase
Data version
5.1
Document digest
990e3a8ed526d721e0584f174aecd02d924d40f980258d39f7737b14694f9162

05 Affected products

VendorProductVersionsPlatforms
PostgreSQL Global Development GroupPostgreSQLbefore 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2—

06 References

07 Fixed in

Ubuntu 14.04 LTS

  • postgresql-9.1
    Fixed in 9.1.16-0ubuntu0.14.04
  • postgresql-9.3
    Fixed in 9.3.7-0ubuntu0.14.04

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.