CVE-2015-1855
verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers
02 Description
verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.81% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 86.3% of scored records. A rank, not a probability.
- NVD base score
- 5.9 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-11-29 20:46Z6 YR AGO
- Last updated
- 2024-08-06 04:54Z2 YR AGO
- Reserved
- 2015-02-17
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- c338681d277fb816955cdbc929b4c5bce722ee41d18cd7d1ebc6896b4cd6c538
05 Affected products
06 References
- www.debian.orghttp://www.debian.org/security/2015/dsa-3247
- www.debian.orghttp://www.debian.org/security/2015/dsa-3245
- www.debian.orghttp://www.debian.org/security/2015/dsa-3246
- www.ruby-lang.orghttps://www.ruby-lang.org/en/news/2015/04/13/ruby-openssl-hostname-matching-vulnerability/
- puppetlabs.comhttps://puppetlabs.com/security/cve/cve-2015-1855
- bugs.ruby-lang.orghttps://bugs.ruby-lang.org/issues/9644
07 Fixed in
Ubuntu 14.04 LTS
- ruby1.9.1 Fixed in 1.9.3.484-2ubuntu1.3
- ruby2.0 Fixed in 2.0.0.484-1ubuntu2.4
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.