synced 3 MIN AGO
01 Record

CVE-2015-0241

The to_char function in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allows remote authenticated users to cause a denial of service

UnratedPUBLISHEDCNA: redhat
CNA base scoreUnratedNo CNA CVSS vector

02 Description

The to_char function in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allows remote authenticated users to cause a denial of service

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
5.53% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 92.6% of scored records. A rank, not a probability.
NVD base score
8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
Moderate. Red Hat's rating for its own products, not a CVSS rating.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2020-01-27 15:29Z6 YR AGO
Last updated
2024-08-06 04:03Z2 YR AGO
Reserved
2014-11-18
Assigning CNA
redhat
Record state
PUBLISHED
Severity
Not rated by the issuing CNA
CNA CVSS vector
Not published by the issuing CNA
Weaknesses
  • CWE-120Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')Base
  • CWE-122Heap-based Buffer OverflowVariant
Data version
5.1
Document digest
d4d7566b9488346dcb3c2378959e507b0173f8c5fcdfc1d50fe5e00ab1d09857

05 Affected products

VendorProductVersionsPlatforms
PostgreSQL Global Development GroupPostgreSQLbefore 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, 9.4.x before 9.4.1—

06 References

07 Fixed in

Ubuntu 14.04 LTS

  • postgresql-9.1
    Fixed in 9.1.15-0ubuntu0.14.04
  • postgresql-9.3
    Fixed in 9.3.6-0ubuntu0.14.04

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.