CVE-2014-6272
Multiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or
02 Description
Multiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.08% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 81.4% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2015-08-24 14:00Z11 YR AGO
- Last updated
- 2024-08-06 12:10Z2 YR AGO
- Reserved
- 2014-09-09
- Assigning CNA
- debian
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- db2d9f9b6c590363e57ace7b2d88a775d61e331dbdfac3c569207f3ea7d5a676
05 Affected products
06 References
- archives.seul.org[Libevent-users] 20150105 Advisory: integer overflow in evbuffers for Libevent <= 1.4.14b,2.0.21,2.1.4-alpha [CVE-2014-6272]http://archives.seul.org/libevent/users/Jan-2015/msg00010.html
- www.debian.orgDSA-3119http://www.debian.org/security/2015/dsa-3119
- puppet.comhttps://puppet.com/security/cve/CVE-2014-6272
- www.slackware.comSSA:2016-085-01http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.366317
07 Fixed in
Debian 12
- libevent Fixed in 2.0.21-stable-2
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- libevent Fixed in 2.0.21-stable-2
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- libevent Fixed in 2.0.21-stable-2
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- libevent Fixed in 2.0.21-stable-1ubuntu1.14.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.