CVE-2014-4660
Ansible before 1.5.5 constructs filenames containing user and password fields on the basis of deb lines in sources.list, which might allow local users to obtain sensitive credential information in
02 Description
Ansible before 1.5.5 constructs filenames containing user and password fields on the basis of deb lines in sources.list, which might allow local users to obtain sensitive credential information in
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 0.38% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 32.0% of scored records. A rank, not a probability.
- NVD base score
- 5.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2020-02-20 02:08Z6 YR AGO
- Last updated
- 2024-08-06 11:20Z2 YR AGO
- Reserved
- 2014-06-25
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-522Insufficiently Protected CredentialsClass
- Data version
- 5.1
- Document digest
- 509cd992f45bbec70ebffe8bcd7a0cde6be5a30d1aa0012f9ee39137a1705703
05 Affected products
06 References
- github.comhttps://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- www.securityfocus.comhttps://www.securityfocus.com/bid/68231
- www.openwall.comhttps://www.openwall.com/lists/oss-security/2014/06/26/19
- security-tracker.debian.orghttps://security-tracker.debian.org/tracker/CVE-2014-4660
- github.comhttps://github.com/ansible/ansible/commit/c4b5e46054c74176b2446c82d4df1a2610eddc08
07 Fixed in
Debian 12
- ansible Fixed in 1.5.5+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- ansible Fixed in 1.5.5+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- ansible Fixed in 1.5.5+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 14.04 LTS
- ansible Fixed in 1.5.4+dfsg-1ubuntu0.1~esm2Available with Ubuntu Pro (Infra-only): https://ubuntu.com/pro
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.