CVE-2014-2669
Multiple integer overflows in contrib/hstore/hstore_io.c in PostgreSQL 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to have
02 Description
Multiple integer overflows in contrib/hstore/hstore_io.c in PostgreSQL 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to have
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 3.50% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 88.8% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Important. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2014-03-28 17:00Z12 YR AGO
- Last updated
- 2024-08-06 10:21Z2 YR AGO
- Reserved
- 2014-03-28
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- 1e940cdce7b472ed35f768f8e7dcc10bcc227bfdc53814b08878925503834f67
05 Affected products
06 References
- rhn.redhat.comRHSA-2014:0221http://rhn.redhat.com/errata/RHSA-2014-0221.html
- rhn.redhat.comRHSA-2014:0469http://rhn.redhat.com/errata/RHSA-2014-0469.html
- github.comhttps://github.com/postgres/postgres/commit/31400a673325147e1205326008e32135a78b4d8a
- wiki.postgresql.orghttp://wiki.postgresql.org/wiki/20140220securityrelease
- www.debian.orgDSA-2864http://www.debian.org/security/2014/dsa-2864
- www.postgresql.orghttp://www.postgresql.org/support/security/
- www.postgresql.orghttp://www.postgresql.org/about/news/1506/
- www.debian.orgDSA-2865http://www.debian.org/security/2014/dsa-2865
07 Fixed in
Ubuntu 14.04 LTS
- postgresql-9.1 Fixed in 9.1.12-1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.