CVE-2013-2038
The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA
02 Description
The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 4.15% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 90.4% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-16.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2014-02-06 16:00Z12 YR AGO
- Last updated
- 2024-08-06 15:20Z2 YR AGO
- Reserved
- 2013-02-19
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-20Improper Input ValidationClass
- Data version
- 5.1
- Document digest
- 3977f38556efa33e20c68c538a981d24b27d24cd672b05998bd6c177fb7251eb
05 Affected products
06 References
- git.savannah.gnu.orghttp://git.savannah.gnu.org/cgit/gpsd.git/commit/?id=dd9c3c2830cb8f8fd8491ce68c82698dc5538f50
- www.osvdb.org93000http://www.osvdb.org/93000
- ubuntu.comUSN-1820-1http://ubuntu.com/usn/usn-1820-1
- openwall.com[oss-security] 20130507 Re: CVE Request -- gpsd 3.9 fixing a denial of service flawhttp://openwall.com/lists/oss-security/2013/05/08/1
- openwall.com[oss-security] 20130502 Re: CVE Request -- gpsd 3.9 fixing a denial of service flawhttp://openwall.com/lists/oss-security/2013/05/02/20
- lists.nongnu.org[gpsd-dev] 20130501 3.9 is releasedhttp://lists.nongnu.org/archive/html/gpsd-dev/2013-05/msg00000.html
- www.osvdb.org93001http://www.osvdb.org/93001
07 Fixed in
Debian 12
- gpsd Fixed in 3.6-5
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- gpsd Fixed in 3.6-5
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- gpsd Fixed in 3.6-5
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.