CVE-2012-6708
jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery
02 Description
jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 8.63% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 94.8% of scored records. A rank, not a probability.
- NVD base score
- 6.1 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-16.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-01-18 23:00Z8 YR AGO
- Last updated
- 2024-08-06 21:36Z2 YR AGO
- Reserved
- 2018-01-18
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.1
- Document digest
- d73652459e1fe2a1a7fcb1a077c3d0196a3eb90679c13dbc555211ac23c63b86
05 Affected products
06 References
- snyk.iohttps://snyk.io/vuln/npm:jquery:20120206
- bugs.jquery.comhttps://bugs.jquery.com/ticket/11290
- github.comhttps://github.com/jquery/jquery/commit/05531fc4080ae24070930d15ae0cea7ae056457d
- help.ecostruxureit.comhttps://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0
- www.securityfocus.com102792http://www.securityfocus.com/bid/102792
- packetstormsecurity.comhttp://packetstormsecurity.com/files/153237/RetireJS-CORS-Issue-Script-Execution.html
- lists.apache.org[drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilitieshttps://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442%40%3Cdev.drill.apache.org%3E
- lists.apache.org[drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilitieshttps://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f%40%3Cdev.drill.apache.org%3E
- lists.apache.org[drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilitieshttps://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc%40%3Cissues.drill.apache.org%3E
- lists.opensuse.orgopenSUSE-SU-2020:0395http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00041.html
- packetstormsecurity.comhttp://packetstormsecurity.com/files/161972/Linksys-EA7500-2.0.8.194281-Cross-Site-Scripting.html
07 Fixed in
Arch Linux
- ruby-rdoc Fixed in 6.1.2-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Ubuntu Pro 14.04 LTS
- jquery Fixed in 1.7.2+dfsg-2ubuntu1+esm1Available with Ubuntu Pro with Legacy support add-on: https://ubuntu.com/pro
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.