synced 3 MIN AGO
01 Record

CVE-2012-6687

FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.

UnratedPUBLISHEDCNA: mitre
CNA base scoreUnratedNo CNA CVSS vector

02 Description

FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
6.08% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 93.2% of scored records. A rank, not a probability.
NVD base score
The NVD has published no score for this record
NVD CVSS vector
No NVD score to derive
NVD analysis status
Modified. NVD last modified this record on 2026-06-16.
Red Hat severity
Moderate. Red Hat's rating for its own products, not a CVSS rating.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2015-02-19 15:00Z11 YR AGO
Last updated
2024-08-06 21:36Z2 YR AGO
Reserved
2015-02-07
Assigning CNA
mitre
Record state
PUBLISHED
Severity
Not rated by the issuing CNA
CNA CVSS vector
Not published by the issuing CNA
Weaknesses
  • CWE-20Improper Input ValidationClass
Data version
5.1
Document digest
001cfb630ab739f7f2c08ce9e3836fc3a9bdfa08217496b991cbd1c99e559991

05 Affected products

VendorProductVersionsPlatforms
fastcgifcgiNot specified—
redhatceph_storageNot specified—

06 References

07 Fixed in

Debian 12

  • libfcgi
    Fixed in 2.4.0-8.3
  • libfcgi-perl
    Fixed in 0.78-2

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

Debian 13

  • libfcgi
    Fixed in 2.4.0-8.3
  • libfcgi-perl
    Fixed in 0.78-2

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

Debian 14

  • libfcgi
    Fixed in 2.4.0-8.3
  • libfcgi-perl
    Fixed in 0.78-2

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.