CVE-2012-2126
RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.
02 Description
RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.36% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 71.2% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-16.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2013-10-01 17:00Z13 YR AGO
- Last updated
- 2024-08-06 19:26Z2 YR AGO
- Reserved
- 2012-04-04
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- 0ba7c42342a27224db08ad656719180e31983165344781f2a8c4724bb0f4e897
05 Affected products
06 References
- secunia.com55381http://secunia.com/advisories/55381
- www.ubuntu.comUSN-1582-1http://www.ubuntu.com/usn/USN-1582-1/
- github.comhttps://github.com/rubygems/rubygems/blob/1.8/History.txt
- rhn.redhat.comRHSA-2013:1203http://rhn.redhat.com/errata/RHSA-2013-1203.html
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=814718
- www.openwall.com[oss-security] 20120420 Re: CVE Request -- rubygems: Two security fixes in upstream v1.8.23 versionhttp://www.openwall.com/lists/oss-security/2012/04/20/24
- rhn.redhat.comRHSA-2013:1852http://rhn.redhat.com/errata/RHSA-2013-1852.html
- rhn.redhat.comRHSA-2013:1441http://rhn.redhat.com/errata/RHSA-2013-1441.html
07 Fixed in
Debian 12
- rubygems Fixed in 1.8.24-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- rubygems Fixed in 1.8.24-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- rubygems Fixed in 1.8.24-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 14.04 LTS
- jruby No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.