CVE-2011-4956
Cross-site scripting (XSS) vulnerability in WordPress before 3.1.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
02 Description
Cross-site scripting (XSS) vulnerability in WordPress before 3.1.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.51% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 84.3% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-16.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2012-06-27 21:00Z14 YR AGO
- Last updated
- 2024-09-16 17:18Z2 YR AGO
- Reserved
- 2011-12-23
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.1
- Document digest
- 77d0cac06f9b781f1a73339ef6359fa6cc0bd6bcda3468322878687463301d9e
05 Affected products
06 References
- www.openwall.com[oss-security] 20120419 Re: CVE-request: WordPress 3.1.1http://www.openwall.com/lists/oss-security/2012/04/19/17
- secunia.com44038http://secunia.com/advisories/44038
- wordpress.orghttp://wordpress.org/news/2011/04/wordpress-3-1-1/
- secunia.com49138http://secunia.com/advisories/49138
- www.openwall.com[oss-security] 20120419 Re: CVE-request: WordPress 3.1.1http://www.openwall.com/lists/oss-security/2012/04/19/6
- www.debian.orgDSA-2470http://www.debian.org/security/2012/dsa-2470
- www.osvdb.org72141http://www.osvdb.org/72141
07 Fixed in
Debian 12
- wordpress Fixed in 3.2.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 3.2.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 3.2.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.