CVE-2010-1628
Ghostscript 8.64, 8.70, and possibly other versions allows context-dependent attackers to execute arbitrary code via a PostScript file containing unlimited recursive procedure invocations, which
02 Description
Ghostscript 8.64, 8.70, and possibly other versions allows context-dependent attackers to execute arbitrary code via a PostScript file containing unlimited recursive procedure invocations, which
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 4.04% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 90.2% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-16.
- Red Hat severity
- Important. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2010-05-19 22:00Z16 YR AGO
- Last updated
- 2024-08-07 01:28Z2 YR AGO
- Reserved
- 2010-04-29
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-119Improper Restriction of Operations within the Bounds of a Memory BufferClass
- Data version
- 5.1
- Document digest
- 08d89e483d1cc49698f6dffefcf51de9737441ad0853dbe9332ffc29e74ac264
05 Affected products
06 References
- secunia.com39753http://secunia.com/advisories/39753
- seclists.org20100511 Multiple memory corruption vulnerabilities in Ghostscripthttp://seclists.org/fulldisclosure/2010/May/134
- security.gentoo.orgGLSA-201412-17http://security.gentoo.org/glsa/glsa-201412-17.xml
- www.securityfocus.com40107http://www.securityfocus.com/bid/40107
- www.mandriva.comMDVSA-2010:134http://www.mandriva.com/security/advisories?name=MDVSA-2010:134
- www.openwall.com[oss-security] 20100518 Re: CVE assignment: ghostscript stack-based overflowhttp://www.openwall.com/lists/oss-security/2010/05/18/7
- www.vupen.comADV-2010-1138http://www.vupen.com/english/advisories/2010/1138
- www.ubuntu.comUSN-961-1http://www.ubuntu.com/usn/USN-961-1
- bugs.ghostscript.comhttp://bugs.ghostscript.com/show_bug.cgi?id=691295
- secunia.com40580http://secunia.com/advisories/40580
- lists.opensuse.orgSUSE-SR:2010:014http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html
- www.securityfocus.com20100512 Multiple memory corruption vulnerabilities in Ghostscripthttp://www.securityfocus.com/archive/1/511243/100/0/threaded
- www.openwall.com[oss-security] 20100511 Re: CVE assignment: ghostscript stack-based overflowhttp://www.openwall.com/lists/oss-security/2010/05/12/1
- bugs.launchpad.nethttps://bugs.launchpad.net/ubuntu/+source/ghostscript/+bug/546009
07 Fixed in
Debian 12
- ghostscript Fixed in 8.71~dfsg2-4
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- ghostscript Fixed in 8.71~dfsg2-4
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- ghostscript Fixed in 8.71~dfsg2-4
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.