CVE-2007-5710
Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.
02 Description
Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 7.00% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 94.0% of scored records. A rank, not a probability.
- NVD base score
- The NVD has published no score for this record
- NVD CVSS vector
- No NVD score to derive
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-16.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2007-10-30 19:00Z19 YR AGO
- Last updated
- 2024-08-07 15:39Z2 YR AGO
- Reserved
- 2007-10-30
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.1
- Document digest
- 878581401ecff34ad98681fd0758b3196c4c6620ae1bf667f0b8dd90c510af60
05 Affected products
06 References
- www.securityfocus.com26228http://www.securityfocus.com/bid/26228
- osvdb.org38279http://osvdb.org/38279
- www.vupen.comADV-2007-3640http://www.vupen.com/english/advisories/2007/3640
- secunia.com27407http://secunia.com/advisories/27407
- exchange.xforce.ibmcloud.comwordpress-editpostrows-xss(38166)https://exchange.xforce.ibmcloud.com/vulnerabilities/38166
- www.waraxe.ushttp://www.waraxe.us/advisory-59.html
- wordpress.orghttp://wordpress.org/development/2007/10/wordpress-231/
- www.securityfocus.com20071027 [waraxe-2007-SA#059] - XSS in WordPress 2.3http://www.securityfocus.com/archive/1/482905/100/0/threaded
07 Fixed in
Debian 12
- wordpress Fixed in 2.3.1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 2.3.1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 2.3.1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.